Packages
Package directory
Synced from the official npm, PyPI, crates.io and RubyGems registries: version, license, description and (where available) weekly download volume.
proc-macro2
crates.ioA substitute implementation of the compiler's `proc_macro` API to decouple token-based libraries from the procedural macro use case.
cfg-if
crates.ioA macro to ergonomically define an item depending on a large number of #[cfg] parameters. Structured like an if-else chain, the first matching branch is the item that gets emitted.
memchr
crates.ioProvides extremely fast (uses SIMD on x86_64, aarch64 and wasm32) routines for 1, 2 or 3 byte search and single substring search.
unicode-ident
crates.ioDetermine whether characters have the XID_Start or XID_Continue properties according to Unicode Standard Annex #31
cc
crates.ioA build-time dependency for Cargo build scripts to assist in invoking the native C compiler to compile native C code into a static archive to be linked into Rust code.
regex
crates.ioAn implementation of regular expressions for Rust. This implementation uses finite automata and guarantees linear time matching on all inputs.
symfony/event-dispatcher
PackagistProvides tools that allow your application components to communicate with each other by dispatching events and listening to them
strsim
crates.ioImplementations of string similarity metrics. Includes Hamming, Levenshtein, OSA, Damerau-Levenshtein, Jaro, Jaro-Winkler, and Sørensen-Dice.
phpunit/php-code-coverage
PackagistLibrary that provides collection, processing, and rendering functionality for PHP code coverage information.
doctrine/inflector
PackagistPHP Doctrine Inflector is a small library that can perform string manipulations with regard to upper/lowercase and singular/plural forms of words.
scopeguard
crates.ioA RAII scope guard that will run a given closure when it goes out of scope, even if the code between panics (assuming unwinding panic). Defines the macros `defer!`, `defer_on_unwind!`, `defer_on_success!` as shorthands for guards with one of the implemented strategies.
cpufeatures
crates.ioLightweight runtime CPU feature detection for aarch64, loongarch64, and x86/x86_64 targets, with no_std support and support for mobile targets including Android and iOS
sha2
crates.ioPure Rust implementation of the SHA-2 hash function family including SHA-224, SHA-256, SHA-384, and SHA-512.
toml
crates.ioA native Rust encoder and decoder of TOML-formatted files and streams. Provides implementations of the standard Serialize/Deserialize traits for TOML data to facilitate deserializing and serializing Rust structures.
time
crates.ioDate and time library. Fully interoperable with the standard library. Mostly compatible with #![no_std].
typenum
crates.ioTypenum is a Rust library for type-level numbers evaluated at compile time. It currently supports bits, unsigned integers, and signed integers. It also provides a type-level array of type-level numbers, but its implementation is incomplete.
symfony/string
PackagistProvides an object-oriented API to strings and deals with bytes, UTF-8 code points and grapheme clusters in a unified way
rails
RubyGemsRuby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.
phpdocumentor/reflection-docblock
PackagistWith this component, a library can provide support for annotations via DocBlocks or otherwise retrieve information that is embedded in a DocBlock.
futures
crates.ioAn implementation of futures and streams featuring zero allocations, composability, and iterator-like interfaces.
pkg-config
crates.ioA library to run the pkg-config system tool at build time in order to be used in Cargo build scripts.
vlucas/phpdotenv
PackagistLoads environment variables from `.env` to `$_ENV` and `$_SERVER` automagically, and optionally to `getenv()`.
darling_macro
crates.ioInternal support for a proc-macro library for reading attributes into structs when implementing custom derives. Use https://crates.io/crates/darling in your code.
darling_core
crates.ioHelper crate for proc-macro library for reading attributes into structs when implementing custom derives. Use https://crates.io/crates/darling in your code.
time-macros
crates.ioProcedural macros for the time crate. This crate is an implementation detail and should not be relied upon directly.
doctrine/dbal
PackagistPowerful PHP database abstraction layer (DBAL) with many features for database schema introspection and management.
doctrine/cache
PackagistPHP Doctrine Cache library is a popular cache implementation that supports many different drivers such as redis, memcache, apc, mongodb and others.
zeroize
crates.ioSecurely clear secrets from memory with a simple trait built on stable Rust primitives which guarantee memory is zeroed using an operation will not be 'optimized away' by the compiler. Uses a portable pure Rust implementation that works everywhere, even WASM!
flate2
crates.ioDEFLATE compression and decompression exposed as Read/BufRead/Write streams. Supports miniz_oxide and multiple zlib implementations. Supports zlib, gzip, and raw deflate streams.
anstream
crates.ioIO stream adapters for writing colored text that will gracefully degrade according to your terminal's capabilities.
stable_deref_trait
crates.ioAn unsafe marker trait for types like Box and Rc that dereference to a stable address even when moved, and hence can be used with libraries such as owning_ref and rental.
tijsverkoyen/css-to-inline-styles
PackagistCssToInlineStyles is a class that enables you to convert HTML-pages/files into HTML-pages/files with inline styles. This is very useful when you're sending emails.
unicode-xid
crates.ioDetermine whether characters have the XID_Start or XID_Continue properties according to Unicode Standard Annex #31.
doctrine/deprecations
PackagistA small layer on top of trigger_error(E_USER_DEPRECATED) or PSR-3 logging with options to disable all deprecations or selectively for packages.
openssl-probe
crates.ioA library for helping to find system-wide trust anchor ("root") certificate locations based on paths typically used by `openssl`.
doctrine/event-manager
PackagistThe Doctrine Event Manager is a simple PHP event system that was built to be used with the various Doctrine projects.
unicode-normalization
crates.ioThis crate provides functions for normalization of Unicode strings, including Canonical and Compatible Decomposition and Recomposition, as described in Unicode Standard Annex #15.
ipnet
crates.ioProvides types and useful methods for working with IPv4 and IPv6 network addresses, commonly called IP prefixes. The new `IpNet`, `Ipv4Net`, and `Ipv6Net` types build on the existing `IpAddr`, `Ipv4Addr`, and `Ipv6Addr` types already provided in Rust's standard library and align to their design to stay consistent. The module also provides useful traits that extend `Ipv4Addr` and `Ipv6Addr` with methods for `Add`, `Sub`, `BitAnd`, and `BitOr` operations. The module only uses stable feature so it is guaranteed to compile using the stable toolchain.
arrayvec
crates.ioA vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.
unicode-segmentation
crates.ioThis crate provides Grapheme Cluster, Word and Sentence boundaries according to Unicode Standard Annex #29 rules.
firebase/php-jwt
PackagistA simple library to encode and decode JSON Web Tokens (JWT) in PHP. Should conform to the current spec.
num-conv
crates.io`num_conv` is a crate to convert between integer types without using `as` casts. This provides better certainty when refactoring, makes the exact behavior of code more explicit, and allows using turbofish syntax.
powerfmt
crates.io`powerfmt` is a library that provides utilities for formatting values. This crate makes it significantly easier to support filling to a minimum width with alignment, avoid heap allocation, and avoid repetitive calculations.
libloading
crates.ioBindings around the platform's dynamic library loading primitives with greatly improved memory safety.
league/commonmark
PackagistHighly-extensible PHP Markdown parser which fully supports the CommonMark spec and GitHub-Flavored Markdown (GFM)
nette/utils
Packagist🛠 Nette Utils: lightweight utilities for string & array manipulation, image handling, safe JSON encoding/decoding, validation, slug or strong password generating etc.
js-sys
crates.ioBindings for all JS global objects and functions in all JS environments like Node.js and browsers, built on `#[wasm_bindgen]` using the `wasm-bindgen` crate.
vcpkg
crates.ioA library to find native dependencies in a vcpkg tree at build time in order to be used in Cargo build scripts.
half
crates.ioHalf-precision floating point f16 and bf16 types for Rust implementing the IEEE 754-2008 standard binary16 and bfloat16 types.
der
crates.ioPure Rust embedded-friendly implementation of the Distinguished Encoding Rules (DER) for Abstract Syntax Notation One (ASN.1) as described in ITU X.690 with full support for heapless `no_std`/`no_alloc` targets
textwrap
crates.ioLibrary for word wrapping, indenting, and dedenting strings. Has optional support for Unicode and emojis as well as machine hyphenation.
const-oid
crates.ioConst-friendly implementation of the ISO/IEC Object Identifier (OID) standard as defined in ITU X.660, with support for BER/DER encoding/decoding as well as heapless no_std (i.e. embedded) support
doctrine/common
PackagistPHP Doctrine Common project is a library that provides additional functionality that other Doctrine projects depend on such as better reflection support, proxies and much more.
spki
crates.ioX.509 Subject Public Key Info (RFC5280) describing public keys as well as their associated AlgorithmIdentifiers (i.e. OIDs)
winapi-x86_64-pc-windows-gnu
crates.ioImport libraries for the x86_64-pc-windows-gnu target. Please don't use this crate directly, depend on winapi instead.
winapi-i686-pc-windows-gnu
crates.ioImport libraries for the i686-pc-windows-gnu target. Please don't use this crate directly, depend on winapi instead.
pkcs8
crates.ioPure Rust implementation of Public-Key Cryptography Standards (PKCS) #8: Private-Key Information Syntax Specification (RFC 5208), with additional support for PKCS#8v2 asymmetric key packages (RFC 5958)
base64ct
crates.ioPure Rust implementation of Base64 (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best effort" constant-time operation and embedded-friendly no_std support
symfony/serializer
PackagistHandles serializing and deserializing data structures, including object graphs, into array structures or other formats like XML and JSON.
maennchen/zipstream-php
PackagistZipStream is a library for dynamically streaming dynamic zip files from PHP without writing to the disk at all on the server.
doctrine/persistence
PackagistThe Doctrine Persistence project is a set of shared interfaces and functionality that the different Doctrine object mappers share.
instant
crates.ioUnmaintained, consider using web-time instead - A partial replacement for std::time::Instant that works on WASM to.
symfony/browser-kit
PackagistSimulates the behavior of a web browser, allowing you to make requests, click on links and submit forms programmatically
dirs
crates.ioA tiny low-level library that provides platform-specific standard locations of directories for config, cache and other data on Linux, Windows, macOS and Redox by leveraging the mechanisms defined by the XDG base/user directory specifications on Linux, the Known Folder API on Windows, and the Standard Directory guidelines on macOS.
bincode
crates.ioA binary serialization / deserialization strategy for transforming structs into bytes and vice versa!
pem-rfc7468
crates.ioPEM Encoding (RFC 7468) for PKIX, PKCS, and CMS Structures, implementing a strict subset of the original Privacy-Enhanced Mail encoding intended specifically for use with cryptographic keys, certificates, and other messages. Provides a no_std-friendly, constant-time implementation suitable for use with cryptographic private keys.
tokio-native-tls
crates.ioAn implementation of TLS/SSL streams for Tokio using native-tls giving an implementation of TLS for nonblocking I/O streams.
num
crates.ioA collection of numeric types and traits for Rust, including bigint, complex, rational, range iterators, generic integers, and more!
num_enum_derive
crates.ioInternal implementation details for ::num_enum (Procedural macros to make inter-operation between primitives and enums easier)
crypto-bigint
crates.ioPure Rust implementation of a big integer library which has been designed from the ground-up for use in cryptographic applications. Provides constant-time, no_std-friendly implementations of modern formulas using const generics.
fs_extra
crates.ioExpanding std::fs and std::io. Recursively copy folders with information about process and much more.
brotli-decompressor
crates.ioA brotli decompressor that with an interface avoiding the rust stdlib. This makes it suitable for embedded devices and kernels. It is designed with a pluggable allocator so that the standard lib's allocator may be employed. The default build also includes a stdlib allocator and stream interface. Disable this with --features=no-stdlib. Alternatively, --features=unsafe turns off array bounds checks and memory initialization but provides a safe interface for the caller. Without adding the --features=unsafe argument, all included code is safe. For compression in addition to this library, download https://github.com/dropbox/rust-brotli
brotli
crates.ioA brotli compressor and decompressor that with an interface avoiding the rust stdlib. This makes it suitable for embedded devices and kernels. It is designed with a pluggable allocator so that the standard lib's allocator may be employed. The default build also includes a stdlib allocator and stream interface. Disable this with --features=no-stdlib. All included code is safe.
crc-catalog
crates.ioCatalog of CRC algorithms (generated from http://reveng.sourceforge.net/crc-catalogue) expressed as simple Rust structs.
doctrine/migrations
PackagistPHP Doctrine Migrations project offer additional functionality on top of the database abstraction layer (DBAL) for versioning your database schema and easily deploying changes to it. It is a very easy to use and a powerful tool.
globset
crates.ioCross platform single glob and glob set matching. Glob set matching is the process of matching one or more glob patterns against a single candidate path simultaneously, and returning all of the globs that matched.
cookie
crates.ioHTTP cookie parsing and cookie jar management. Supports signed and private (encrypted, authenticated) jars.
tar
crates.ioA Rust implementation of a TAR file reader and writer. This library does not currently handle compression, but it is abstract over all I/O readers and writers. Additionally, great lengths are taken to ensure that the entire contents are never required to be entirely resident in memory all at once.
base16ct
crates.ioPure Rust implementation of Base16 a.k.a hexadecimal (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best effort" constant-time operation and embedded-friendly no_std support
alloc-no-stdlib
crates.ioA dynamic allocator that may be used with or without the stdlib. This allows a package with nostd to allocate memory dynamically and be used either with a custom allocator, items on the stack, or by a package that wishes to simply use Box<>. It also provides options to use calloc or a mutable global variable for pre-zeroed memory
elliptic-curve
crates.ioGeneral purpose Elliptic Curve Cryptography (ECC) support, including traits and generic types for representing various elliptic curve forms, scalars, points, and public/secret keys composed thereof.
composer/composer
PackagistComposer helps you declare, manage and install dependencies of PHP projects. It ensures you have the right stack everywhere.
wit-bindgen
crates.ioRust bindings generator and runtime support for WIT and the component model. Used when compiling Rust programs to the component model.
ecdsa
crates.ioPure Rust implementation of the Elliptic Curve Digital Signature Algorithm (ECDSA) as specified in FIPS 186-4 (Digital Signature Standard), implemented generically over elliptic curves, providing RFC6979 deterministic signing support as well as randomized signatures and signature verification
sec1
crates.ioPure Rust implementation of SEC1: Elliptic Curve Cryptography encoding formats including ASN.1 DER encoded private keys as well as the Elliptic-Curve-Point-to-Octet-String encoding
ed25519
crates.ioEdwards Digital Signature Algorithm (EdDSA) over Curve25519 (as specified in RFC 8032) support library providing signature type definitions and PKCS#8 private key decoding/encoding support
fancy-regex
crates.ioAn implementation of regexes, supporting a relatively rich set of features, including backreferences and look-around. Aims to be compatible with Oniguruma syntax when the relevant flag is set.
rfc6979
crates.ioPure Rust implementation of RFC6979: Deterministic Usage of the Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)
symfony/asset
PackagistManages URL generation and versioning of web assets such as CSS stylesheets, JavaScript files and image files
pkcs1
crates.ioPure Rust implementation of Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.2 (RFC 8017)
aws-lc-sys
crates.ioAWS-LC is a general-purpose cryptographic library maintained by the AWS Cryptography team for AWS and their customers. It іs based on code from the Google BoringSSL project and the OpenSSL project.
aws-lc-rs
crates.ioaws-lc-rs is a cryptographic library using AWS-LC for its cryptographic operations. This library strives to be API-compatible with the popular Rust library named ring.
aead
crates.ioTraits for Authenticated Encryption with Associated Data (AEAD) algorithms, such as AES-GCM as ChaCha20Poly1305, which provide a high-level API
scoped-tls
crates.ioLibrary implementation of the standard library's old `scoped_thread_local!` macro for providing scoped access to thread local storage (TLS) so any type can be stored into TLS.
mobiledetect/mobiledetectlib
PackagistMobile_Detect is a lightweight PHP class for detecting mobile devices. It uses the User-Agent string combined with specific HTTP headers to detect the mobile environment.
ctor
crates.ioGlobal, no_std-compatible constructors for all platforms that run before main (like C/C++ __attribute__((constructor)))
giggsey/libphonenumber-for-php
PackagistA library for parsing, formatting, storing and validating international phone numbers, a PHP Port of Google's libphonenumber.
chacha20
crates.ioThe ChaCha20 stream cipher (RFC 8439) implemented in pure Rust using traits from the RustCrypto `cipher` crate, with optional architecture-specific hardware acceleration (AVX2, SSE2). Additionally provides the ChaCha8, ChaCha12, XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional rand_core-compatible RNGs based on those ciphers.
setasign/fpdi
PackagistFPDI is a collection of PHP classes facilitating developers to read pages from existing PDF documents and use them as templates in FPDF. Because it is also possible to use FPDI with TCPDF, there are no fixed dependencies defined. Please see suggestions for packages which evaluates the dependencies automatically.
p256
crates.ioPure Rust implementation of the NIST P-256 (a.k.a. secp256r1, prime256v1) elliptic curve as defined in SP 800-186, with support for ECDH, ECDSA signing/verification, and general purpose curve arithmetic
jiff
crates.ioA date-time library that encourages you to jump into the pit of success. This library is heavily inspired by the Temporal project.
dirs-next
crates.ioA tiny low-level library that provides platform-specific standard locations of directories for config, cache and other data on Linux, Windows, macOS and Redox by leveraging the mechanisms defined by the XDG base/user directory specifications on Linux, the Known Folder API on Windows, and the Standard Directory guidelines on macOS.
raw-cpuid
crates.ioA library to parse the x86 CPUID instruction, written in rust with no external dependencies. The implementation closely resembles the Intel CPUID manual description. The library does only depend on libcore.
league/oauth2-server
PackagistA lightweight and powerful OAuth 2.0 authorization and resource server library with support for all the core specification grants. This library will allow you to secure your API with OAuth and allow your applications users to approve apps that want to access their data from your API.
polyval
crates.ioPOLYVAL is a GHASH-like universal hash over GF(2^128) useful for constructing a Message Authentication Code (MAC)
zircote/swagger-php
PackagistGenerate interactive documentation for your RESTful API using PHP attributes (preferred) or PHPDoc annotations
downcast-rs
crates.ioTrait object downcasting support using only safe Rust. It supports type parameters, associated types, and type constraints.
secrecy
crates.ioWrapper types and traits for secret management which help ensure they aren't accidentally copied, logged, or otherwise exposed (as much as possible), and also ensure secrets are securely wiped from memory when dropped.
rails-i18n
RubyGemsA set of common locale data and translations to internationalize and/or localize your Rails applications.
slevomat/coding-standard
PackagistSlevomat Coding Standard for PHP_CodeSniffer complements Consistence Coding Standard by providing sniffs with additional checks.
litrs
crates.ioParse and inspect Rust literals (i.e. tokens in the Rust programming language representing fixed values). Particularly useful for proc macros, but can also be used outside of a proc-macro context.
ghash
crates.ioUniversal hash over GF(2^128) useful for constructing a Message Authentication Code (MAC), as in the AES-GCM authenticated encryption cipher.
aes-gcm
crates.ioPure Rust implementation of the AES-GCM (Galois/Counter Mode) Authenticated Encryption with Associated Data (AEAD) Cipher with optional architecture-specific hardware acceleration
php-amqplib/php-amqplib
PackagistFormerly videlalvaro/php-amqplib. This library is a pure PHP implementation of the AMQP protocol. It's been tested against RabbitMQ.
opentelemetry-http
crates.ioHelper implementations for sending HTTP requests. Uses include propagating and extracting context over http, exporting telemetry, requesting sampling strategies.
rust_decimal
crates.ioDecimal number implementation written in pure Rust suitable for financial and fixed-precision calculations.
sqlx
crates.io🧰 The Rust SQL Toolkit. An async, pure Rust SQL crate featuring compile-time checked queries without a DSL. Supports PostgreSQL, MySQL, and SQLite.
symfony/debug-bundle
PackagistProvides a tight integration of the Symfony VarDumper component and the ServerLogCommand from MonologBridge into the Symfony full-stack framework
matrixmultiply
crates.ioGeneral matrix multiplication for f32 and f64 matrices. Operates on matrices with general layout (they can use arbitrary row and column stride). Detects and uses SIMD features on x86/x86-64 and AArch64 transparently for higher performance. Uses a microkernel strategy, so that the implementation is easy to parallelize and optimize. Supports multithreading.
peeking_take_while
crates.ioLike `Iterator::take_while`, but calls the predicate on a peeked value. This allows you to use `Iterator::by_ref` and `Iterator::take_while` together, and still get the first value for which the `take_while` predicate returned false after dropping the `by_ref`.
symfony/maker-bundle
PackagistSymfony Maker helps you create empty commands, controllers, form classes, tests and more so you can forget about writing boilerplate code.
rawpointer
crates.ioExtra methods for raw pointers and `NonNull<T>`. For example `.post_inc()` and `.pre_dec()` (c.f. `ptr++` and `--ptr`), `offset` and `add` for `NonNull<T>`, and the function `ptrdistance`.
phpmd/phpmd
PackagistPHPMD is a spin-off project of PHP Depend and aims to be a PHP equivalent of the well known Java tool PMD.
rustls-platform-verifier
crates.iorustls-platform-verifier supports verifying TLS certificates in rustls with the operating system verifier
ndarray
crates.ioAn n-dimensional array for general elements and for numerics. Lightweight array views and slicing; views support chunking and splitting.
rstest
crates.ioRust fixture based test framework. It use procedural macro to implement fixtures and table based tests.
primeorder
crates.ioPure Rust implementation of complete addition formulas for prime order elliptic curves (Renes-Costello-Batina 2015). Generic over field elements and curve equation coefficients
git2
crates.ioBindings to libgit2 for interoperating with git repositories. This library is both threadsafe and memory safe and allows both reading and writing git repositories.
roave/security-advisories
PackagistPrevents installation of composer packages with known security vulnerabilities: no API, simply require it
password-hash
crates.ioTraits which describe the functionality of password hashing algorithms, with optional support for a `no_std`/`no_alloc`-friendly implementation of the PHC string format, as well as generic support for other formats (e.g. Modular Crypt Format)
snap
crates.ioA pure Rust implementation of the Snappy compression algorithm. Includes streaming compression and decompression.
Inflector
crates.ioAdds String based inflections for Rust. Snake, kebab, camel, sentence, class, title and table cases as well as ordinalize, deordinalize, demodulize, foreign key, and pluralize/singularize are supported as both traits and pure functions acting on String types.
rgb
crates.io`struct RGB/RGBA/etc.` for sharing pixels between crates + convenience methods for color manipulation. Allows no-copy high-level interoperability. Also adds common convenience methods and implements standard Rust traits to make `RGB`/`RGBA` pixels and slices first-class Rust objects.
rstest_macros
crates.ioRust fixture based test framework. It use procedural macro to implement fixtures and table based tests.
normalize-line-endings
crates.ioTakes an iterator over chars and returns a new iterator with all line endings (\r, \n, or \r\n) as \n
integer-encoding
crates.iovarint+zigzag and fixedint integer encoding/decoding (https://developers.google.com/protocol-buffers/docs/encoding)
match_cfg
crates.ioA convenience macro to ergonomically define an item depending on a large number of `#[cfg]` parameters. Structured like match statement, the first matching branch is the item that gets emitted.
widestring
crates.ioA wide string Rust library for converting to and from wide strings, such as those often used in Windows API or other FFI libaries. Both `u16` and `u32` string types are provided, including support for UTF-16 and UTF-32, malformed encoding, C-style strings, etc.
educe
crates.ioThis crate offers procedural macros designed to facilitate the swift implementation of Rust's built-in traits.
enumflags2_derive
crates.ioDo not use directly, use the reexport in the `enumflags2` crate. This allows for better compatibility across versions.
enum-ordinalize
crates.ioThis library enables enums to not only obtain the ordinal values of their variants but also allows for the construction of enums from an ordinal value.
stacker
crates.ioA stack growth library useful when implementing deeply recursive algorithms that may accidentally blow the stack.
wit-bindgen-core
crates.ioLow-level support for bindings generation based on WIT files for use with `wit-bindgen-cli` and other languages.
wit-bindgen-rust
crates.ioRust bindings generator for WIT and the component model, typically used through the `wit-bindgen` crate's `generate!` macro.
seld/signal-handler
PackagistSimple unix signal handler that silently fails where signals are not supported for easy cross-platform development
triomphe
crates.ioA fork of std::sync::Arc with some extra functionality and without weak references (originally servo_arc)
nalgebra
crates.ioGeneral-purpose linear algebra library with transformations and statically-sized or dynamically-sized matrices.
jsonpath-rust
crates.ioThe library provides the basic functionality to find the set of the data according to the filtering query.
beberlei/doctrineextensions
PackagistA set of extensions to Doctrine 2 that add support for additional query functions available in MySQL, Oracle, PostgreSQL and SQLite.
scc
crates.ioA collection of high-performance asynchronous/concurrent containers with both asynchronous and synchronous interfaces
object_store
crates.ioA generic object store interface for uniformly interacting with AWS S3, Google Cloud Storage, Azure Blob Storage and local files.
hybrid-array
crates.ioHybrid typenum-based and const generic array types designed to provide the flexibility of typenum-based expressions while also allowing interoperability and a transition path to const generics
p384
crates.ioPure Rust implementation of the NIST P-384 (a.k.a. secp384r1) elliptic curve as defined in SP 800-186 with support for ECDH, ECDSA signing/verification, and general purpose curve arithmetic support.
setasign/fpdf
PackagistFPDF is a PHP class which allows to generate PDF files with pure PHP. F from FPDF stands for Free: you may use it for any kind of usage and modify it to suit your needs.
knplabs/knp-snappy
PackagistPHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Wrapper for wkhtmltopdf/wkhtmltoimage.
bit_field
crates.ioSimple bit field trait providing get_bit, get_bits, set_bit, and set_bits methods for Rust's integral types.
webpki-root-certs
crates.ioMozilla trusted certificate authorities in self-signed X.509 format for use with crates other than webpki
chacha20poly1305
crates.ioPure Rust implementation of the ChaCha20Poly1305 Authenticated Encryption with Additional Data Cipher (RFC 8439) with optional architecture-specific hardware acceleration. Also contains implementations of the XChaCha20Poly1305 extended nonce variant of ChaCha20Poly1305, and the reduced-round ChaCha8Poly1305 and ChaCha12Poly1305 lightweight variants.
k256
crates.iosecp256k1 elliptic curve library written in pure Rust with support for ECDSA signing/verification/public-key recovery, Taproot Schnorr signatures (BIP340), Elliptic Curve Diffie-Hellman (ECDH), and general-purpose secp256k1 elliptic curve group operations which can be used to implement arbitrary protocols
enum-ordinalize-derive
crates.ioThis crate provides a procedural macro that enables enums to not only obtain the ordinal values of their variants but also allows for the construction of enums from an ordinal value.
secp256k1
crates.ioRust wrapper library for Pieter Wuille's `libsecp256k1`. Implements ECDSA and BIP 340 signatures for the SECG elliptic curve group secp256k1 and related utilities.
getset
crates.ioGetset, we're ready to go! A procedural macro for generating the most basic getters and setters on fields.
hickory-proto
crates.iohickory-proto is a safe and secure low-level DNS library. This is the foundational DNS protocol library used by the other higher-level Hickory DNS crates.
drush/drush
PackagistDrush is a command line shell and scripting interface for Drupal, a veritable Swiss Army knife designed to make life easier for those of us who spend some of our working hours hacking away at the command prompt.
nette/robot-loader
Packagist🍀 Nette RobotLoader: high performance and comfortable autoloader that will search and autoload classes within your application.
slim/slim
PackagistSlim is a PHP micro framework that helps you quickly write simple yet powerful web applications and APIs
spomky-labs/otphp
PackagistA PHP library for generating one time passwords according to RFC 4226 (HOTP Algorithm) and the RFC 6238 (TOTP Algorithm) and compatible with Google Authenticator
consolidation/filter-via-dot-access-data
PackagistThis project uses dflydev/dot-access-data to provide simple output filtering for applications built with annotated-command / Robo.
swagger-api/swagger-ui
PackagistSwagger UI is a collection of HTML, Javascript, and CSS assets that dynamically generate beautiful documentation from a Swagger-compliant API.
laminas/laminas-validator
PackagistValidation classes for a wide range of domains, and the ability to chain validators to create complex validation criteria
consolidation/site-process
PackagistA thin wrapper around the Symfony Process Component that allows applications to use the Site Alias library to specify the target for a remote call.
symfony/html-sanitizer
PackagistProvides an object-oriented API to sanitize untrusted HTML input for safe insertion into a document's DOM.
transformers
PyPITransformers: the model-definition framework for state-of-the-art machine learning models in text, vision, audio, and multimodal models, for both inference and training.
yoast/phpunit-polyfills
PackagistSet of polyfills for changed PHPUnit functionality to allow for creating PHPUnit cross-version compatible tests
colinmollenhour/credis
PackagistCredis is a lightweight interface to the Redis key-value store which wraps the phpredis library when available for better performance.
spomky-labs/pki-framework
PackagistA PHP framework for managing Public Key Infrastructures. It comprises X.509 public key certificates, attribute certificates, certification requests and certification path validation.
nette/di
Packagist💎 Nette Dependency Injection Container: Flexible, compiled and full-featured DIC with perfectly usable autowiring and support for all new PHP features.
phpoffice/phpword
PackagistPHPWord - A pure PHP library for reading and writing word processing documents (OOXML, ODF, RTF, HTML, PDF)
phpcompatibility/phpcompatibility-paragonie
PackagistA set of rulesets for PHP_CodeSniffer to check for PHP cross-version compatibility issues in projects, while accounting for polyfills provided by the Paragonie polyfill libraries.
phpcompatibility/phpcompatibility-wp
PackagistA ruleset for PHP_CodeSniffer to check for PHP cross-version compatibility issues in projects, while accounting for polyfills provided by WordPress.
matthiasmullie/minify
PackagistCSS & JavaScript minifier, in PHP. Removes whitespace, strips comments, combines files (incl. @import statements and small assets in CSS files), and optimizes/shortens a few common programming patterns.
php-di/phpdoc-reader
PackagistPhpDocReader parses @var and @param values in PHP docblocks (supports namespaced class names with the same resolution rules as PHP)
laminas/laminas-config
Packagistprovides a nested object property based user interface for accessing this configuration data within application code
infection/infection
PackagistInfection is a Mutation Testing framework for PHP. The mutation adequacy score can be used to measure the effectiveness of a test set in terms of its ability to detect faults.
picqer/php-barcode-generator
PackagistAn easy to use, non-bloated, barcode generator in PHP. Creates SVG, PNG, JPG and HTML images from the most used 1D barcode standards.
phootwork/collection
PackagistThe phootwork library fills gaps in the php language and provides better solutions than the existing ones php offers.
laminas/laminas-view
PackagistFast and type safe HTML templating library with a flexible plugin system supporting multistep template composition
matomo/device-detector
PackagistThe Universal Device Detection library, that parses User Agents and detects devices (desktop, tablet, mobile, tv, cars, console, etc.), clients (browsers, media players, mobile apps, feed readers, libraries, etc), operating systems, devices, brands and models.
laravel/boost
PackagistLaravel Boost accelerates AI-assisted development by providing the essential context and structure that AI needs to generate high-quality, Laravel-specific code.
cakephp/datasource
PackagistProvides connection managing and traits for Entities and Queries that can be reused for different datastores
rails_autolink
RubyGemsThis is an extraction of the `auto_link` method from rails. The `auto_link` method was removed from Rails in version Rails 3.1. This gem is meant to bridge the gap for people migrating.
spaze/phpstan-disallowed-calls
PackagistPHPStan rules to detect disallowed method & function calls, constant, namespace, attribute, property & superglobal usages, with powerful rules to re-allow a call or a usage in places where it should be allowed.
drupal/core-dev
Packagistrequire-dev dependencies from drupal/drupal; use in addition to drupal/core-recommended to run tests from drupal/core.
php-mock/php-mock
PackagistPHP-Mock can mock built-in PHP functions (e.g. time()). PHP-Mock relies on PHP's namespace fallback policy. No further extension is needed.
mollie/mollie-api-php
PackagistMollie API client library for PHP. Mollie is a European Payment Service provider and offers international payment methods such as Mastercard, VISA, American Express and PayPal, and local payment methods such as iDEAL, Bancontact, SOFORT Banking, SEPA direct debit, Belfius Direct Net, KBC Payment Button and various gift cards such as Podiumcadeaukaart and fashioncheque.
laravel/pulse
PackagistLaravel Pulse is a real-time application performance monitoring tool and dashboard for your Laravel application.
spiral/roadrunner
PackagistRoadRunner: High-performance PHP application server and process manager written in Go and powered with plugins
zenstruck/foundry
PackagistA model factory library for creating expressive, auto-completable, on-demand dev/test fixtures with Symfony and Doctrine.
laravel-lang/lang
PackagistList of 126 languages for Laravel Framework, Laravel Jetstream, Laravel Fortify, Laravel Breeze, Laravel Cashier, Laravel Nova, Laravel Spark and Laravel UI
amphp/http-client
PackagistAn advanced async HTTP client library for PHP, enabling efficient, non-blocking, and concurrent requests and responses.
rails-settings-cached
RubyGemsThe best solution for store global settings in Rails applications. This gem will managing a table of а global key, value pairs easy. Think of it like a global Hash stored in your database, that uses simple ActiveRecord like methods for manipulation. Keep track of any global setting that you dont want to hard code into your rails app. You can store any kind of object. Strings, numbers, arrays, or any object.
psr-discovery/discovery
PackagistLightweight library that discovers available PSR implementations by searching for a list of well-known classes that implement the relevant interfaces, and returning an instance of the first one that is found.
psr-discovery/http-factory-implementations
PackagistLightweight library that discovers available PSR-17 HTTP Factory implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
psr-discovery/http-client-implementations
PackagistLightweight library that discovers available PSR-18 HTTP Client implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
openai-php/laravel
PackagistOpenAI PHP for Laravel is a supercharged PHP API client that allows you to interact with the Open AI API
psr-discovery/log-implementations
PackagistLightweight library that discovers available PSR-3 Log implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
psr-discovery/cache-implementations
PackagistLightweight library that discovers available PSR-6 Cache implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
psr-discovery/event-dispatcher-implementations
PackagistLightweight library that discovers available PSR-14 Event Dispatcher implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
psr-discovery/container-implementations
PackagistLightweight library that discovers available PSR-11 Container implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
psr-discovery/all
PackagistLightweight library that discovers available PSR implementations by searching for a list of well-known classes that implement the relevant interface, and returns an instance of the first one that is found.
deptrac/deptrac
PackagistDeptrac is a static code analysis tool that helps to enforce rules for dependencies between software layers.
shipmonk/composer-dependency-analyser
PackagistFast detection of composer dependency issues (dead dependencies, shadow dependencies, misplaced dependencies)
rails_event_store
RubyGemsRails wrapper for RubyEventStore with batteries included. Ships with asynchronous after-commit event dispatch on top of ActiveJob, ActiveSupport::Notifications instrumentation enabled, request metadata enrichment and opinionated directory structure generator for bounded contexts.
setasign/tfpdf
PackagistThis class is a modified version of FPDF that adds UTF-8 support. The latest version is based on FPDF 1.85.
sanmai/duoclock
PackagistPHP time mocking for tests - PSR-20 clock with mockable sleep(), time(), and TimeSpy for PHPUnit testing
rails-api
RubyGemsRails::API is a subset of a normal Rails application, created for applications that don't require all functionality that a complete Rails application provides
shipmonk/dead-code-detector
PackagistDead code detector to find unused PHP code via PHPStan extension. Can automatically remove dead PHP code. Supports libraries like Symfony, Doctrine, PHPUnit etc. Detects dead cycles. Can detect dead code that is tested.
rails-backbone
RubyGemsQuickly setup backbone.js for use with rails 3.1 and above apps. Generators are provided to quickly get started.
rails-footnotes
RubyGemsEvery Rails page has footnotes that gives information about your application and links back to your editor.
framework
npmThe (AI) Framework: turnkey, zero-config AI orchestration that wraps a coding-agent CLI (Claude Code) as a black box and takes you from an idea to a running app. Vite for AI.